summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2013-03-28 07:36:44 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2013-03-28 07:36:44 (GMT)
commit0198f40eb58a938f901dac686a48e9635c8d1156 (patch)
tree209d2a079e30e4becaca7dbdbdc4f8575328eb14 /win/configure.in
parentd2775095f0bf50afa0506eca7153d42d0667806a (diff)
downloadtk-0198f40eb58a938f901dac686a48e9635c8d1156.zip
tk-0198f40eb58a938f901dac686a48e9635c8d1156.tar.gz
tk-0198f40eb58a938f901dac686a48e9635c8d1156.tar.bz2
Easier solution, with proper protection and configure warnings.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index 87826fb..c5f09cc 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -91,6 +91,10 @@ if test "${TCL_MINOR_VERSION}" -lt "${TK_MINOR_VERSION}"; then
Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
fi
+if test "${TCL_MINOR_VERSION}" != "${TK_MINOR_VERSION}"; then
+ AC_MSG_WARN([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
+Building Tk ${TK_VERSION} this way results in a binary which is no longer loadable in Tcl ${TK_VERSION}])
+fi
#--------------------------------------------------------------------
# The statements below define a collection of compile flags. This