summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2013-03-27 11:54:48 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2013-03-27 11:54:48 (GMT)
commitbe9d4efe7ba6f645e1cd3e8c93dfa13f634eb972 (patch)
treebf19ce263808d6875f337129402f3865e7770181 /win/configure.in
parent6b4003931a14f890e04b620d349878f3f09a3b4d (diff)
downloadtk-be9d4efe7ba6f645e1cd3e8c93dfa13f634eb972.zip
tk-be9d4efe7ba6f645e1cd3e8c93dfa13f634eb972.tar.gz
tk-be9d4efe7ba6f645e1cd3e8c93dfa13f634eb972.tar.bz2
Same change as [9bc120ced2] for UNIX, but for Windows as well.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index ef517e6..87826fb 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -81,6 +81,17 @@ SC_ENABLE_SHARED
SC_PATH_TCLCONFIG($TK_PATCH_LEVEL)
SC_LOAD_TCLCONFIG
+if test "${TCL_MAJOR_VERSION}" != "${TK_MAJOR_VERSION}"; then
+ AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+fi
+if test "${TCL_MINOR_VERSION}" -lt "${TK_MINOR_VERSION}"; then
+ AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+fi
+
#--------------------------------------------------------------------
# The statements below define a collection of compile flags. This
# macro depends on the value of SHARED_BUILD, and should be called