summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2007-10-15 01:05:27 (GMT)
committerhobbs <hobbs>2007-10-15 01:05:27 (GMT)
commitc01f5d95fcb794f6efcc16569809ef24e6553cf5 (patch)
tree47c06f053f937b1a114fc583cba5b948f7a8d08d /win/configure.in
parent2298c08df19a3ffe677ced4c1c13ad87b7268199 (diff)
downloadtk-c01f5d95fcb794f6efcc16569809ef24e6553cf5.zip
tk-c01f5d95fcb794f6efcc16569809ef24e6553cf5.tar.gz
tk-c01f5d95fcb794f6efcc16569809ef24e6553cf5.tar.bz2
* win/configure, win/configure.in (TK_WIN_VERSION): Make sure the
patchlevel doesn't contain extra dotted pairs (eg. interim release)
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/win/configure.in b/win/configure.in
index d42745a..f975acf 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.68 2007/10/02 18:28:16 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.69 2007/10/15 01:05:28 hobbs Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.59)
@@ -231,9 +231,11 @@ fi
# The wish.exe.manifest requires these
# TK_WIN_VERSION is the 4 dotted pair Windows version format
+# Make sure the patch level doesn't contain extra dotted pairs (interim rel)
+AB_PATCH_LEVEL="`echo $TK_PATCH_LEVEL | sed -e 's/\..*//'`"
case "$TK_PATCH_LEVEL" in
- a*) TK_WIN_VERSION="$TK_VERSION.0.`echo $TK_PATCH_LEVEL | tr -d a`" ;;
- b*) TK_WIN_VERSION="$TK_VERSION.1.`echo $TK_PATCH_LEVEL | tr -d b`" ;;
+ a*) TK_WIN_VERSION="$TK_VERSION.0.`echo $AB_PATCH_LEVEL | tr -d a`" ;;
+ b*) TK_WIN_VERSION="$TK_VERSION.1.`echo $AB_PATCH_LEVEL | tr -d b`" ;;
.*) TK_WIN_VERSION="$TK_VERSION.2$TK_PATCH_LEVEL" ;;
esac
AC_SUBST(TK_WIN_VERSION)