summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2008-06-13 21:29:27 (GMT)
committerhobbs <hobbs>2008-06-13 21:29:27 (GMT)
commitf68e78c668f0a3077f3ddf8235a4359f43a68363 (patch)
tree37a540964a5b7995891d6167422949e61e7b6032 /win/configure.in
parent566e71d20454532cdf0fdb82121121dfed49a701 (diff)
downloadtk-f68e78c668f0a3077f3ddf8235a4359f43a68363.zip
tk-f68e78c668f0a3077f3ddf8235a4359f43a68363.tar.gz
tk-f68e78c668f0a3077f3ddf8235a4359f43a68363.tar.bz2
* win/configure, win/configure.in (TK_WIN_VERSION): fix handling
of interim a/b versioning for manifest usage.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in9
1 files changed, 4 insertions, 5 deletions
diff --git a/win/configure.in b/win/configure.in
index 0038327..7d908a3 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.77.2.1 2008/04/11 19:00:51 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.77.2.2 2008/06/13 21:29:29 hobbs Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.59)
@@ -232,11 +232,10 @@ fi
# The wish.exe.manifest requires these
# TK_WIN_VERSION is the 4 dotted pair Windows version format
# Make sure the patch level doesn't contain extra dotted pairs (interim rel)
-AB_PATCH_LEVEL="`echo $TK_PATCH_LEVEL | sed -e 's/\..*//'`"
case "$TK_PATCH_LEVEL" in
- a*) TK_WIN_VERSION="$TK_VERSION.0.`echo $AB_PATCH_LEVEL | tr -d a`" ;;
- b*) TK_WIN_VERSION="$TK_VERSION.1.`echo $AB_PATCH_LEVEL | tr -d b`" ;;
- .*) TK_WIN_VERSION="$TK_VERSION.2$TK_PATCH_LEVEL" ;;
+ .[[0-9]]a*) TK_WIN_VERSION="$TK_VERSION.0`echo $TK_PATCH_LEVEL | tr -d a`" ;;
+ .[[0-9]]b*) TK_WIN_VERSION="$TK_VERSION.1`echo $TK_PATCH_LEVEL | tr -d b`" ;;
+ *) TK_WIN_VERSION="$TK_VERSION.2$TK_PATCH_LEVEL" ;;
esac
AC_SUBST(TK_WIN_VERSION)
# X86|AMD64|IA64 for manifest