summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2001-06-06 07:58:23 (GMT)
committermdejong <mdejong>2001-06-06 07:58:23 (GMT)
commit019ad61b8b1833368240e189ad1b47b00feaab4c (patch)
treecc1e322ae7f46d171fb4b0c67e7d307e364f7996 /win/configure.in
parentc64411a59027a7aa22f51d8bf6b9e9435f094488 (diff)
downloadtk-019ad61b8b1833368240e189ad1b47b00feaab4c.zip
tk-019ad61b8b1833368240e189ad1b47b00feaab4c.tar.gz
tk-019ad61b8b1833368240e189ad1b47b00feaab4c.tar.bz2
* win/configure: Regen.
* win/configure.in: Handle the --prefix option correctly it should default to /usr/local like the unix version.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index 19e3645..6346044 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -2,7 +2,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.25 2001/04/02 02:08:55 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.26 2001/06/06 07:58:23 mdejong Exp $
AC_INIT(../generic/tk.h)
@@ -13,6 +13,17 @@ TK_PATCH_LEVEL="a3"
VER=$TK_MAJOR_VERSION$TK_MINOR_VERSION
#------------------------------------------------------------------------
+# Handle the --prefix=... option
+#------------------------------------------------------------------------
+
+if test "${prefix}" = "NONE"; then
+ prefix=/usr/local
+fi
+if test "${exec_prefix}" = "NONE"; then
+ exec_prefix=$prefix
+fi
+
+#------------------------------------------------------------------------
# Standard compiler checks
#------------------------------------------------------------------------