summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormo <mo>2000-08-25 05:55:05 (GMT)
committermo <mo>2000-08-25 05:55:05 (GMT)
commit4e40628e20d645ccec764e7147fefaeb120df3cc (patch)
treecdf155021554b342405ec965f7228475bcf4915c /win/configure.in
parent50b9bc1638f4c41a8d83bef8954ee03469089691 (diff)
downloadtk-4e40628e20d645ccec764e7147fefaeb120df3cc.zip
tk-4e40628e20d645ccec764e7147fefaeb120df3cc.tar.gz
tk-4e40628e20d645ccec764e7147fefaeb120df3cc.tar.bz2
remove --enable-gcc configure option
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in30
1 files changed, 22 insertions, 8 deletions
diff --git a/win/configure.in b/win/configure.in
index ef80902..583a554 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -2,7 +2,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.21 2000/07/27 22:52:43 mo Exp $
+# RCS: @(#) $Id: configure.in,v 1.22 2000/08/25 05:55:07 mo Exp $
AC_INIT(../generic/tk.h)
@@ -12,13 +12,27 @@ TK_MINOR_VERSION=4
TK_PATCH_LEVEL="a1"
VER=$TK_MAJOR_VERSION$TK_MINOR_VERSION
-#--------------------------------------------------------------------
-# Check whether --enable-gcc or --disable-gcc was given. Do this
-# before AC_PROG_CC and AC_CYGWIN are called so the compiler can
-# be fully tested by built-in autoconf tools.
-#--------------------------------------------------------------------
-
-SC_ENABLE_GCC
+#------------------------------------------------------------------------
+# Standard compiler checks
+#------------------------------------------------------------------------
+
+AC_PROG_CC
+
+# To properly support cross-compilation, one would
+# need to use these tool checks instead of
+# the ones below and reconfigure with
+# autoconf 2.50. You can also just set
+# the CC, AR, RANLIB, and RC environment
+# variables if you want to cross compile.
+#AC_CHECK_TOOL(AR, ar, :)
+#AC_CHECK_TOOL(RANLIB, ranlib, :)
+#AC_CHECK_TOOL(RC, windres, :)
+
+if test "${GCC}" = "yes" ; then
+ AC_CHECK_PROG(AR, ar, ar)
+ AC_CHECK_PROG(RANLIB, ranlib, ranlib)
+ AC_CHECK_PROG(RC, windres, windres)
+fi
#--------------------------------------------------------------------
# Checks to see if the make progeam sets the $MAKE variable.