summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2012-02-26 21:23:21 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2012-02-26 21:23:21 (GMT)
commit672ad30f66fb7d68caca7ccfd50dfa6abfc551d2 (patch)
treed20b7ae61f1d10e38e101b8aebaa4e3f45efce3c /win/configure.in
parent81cfe79d65941e4793fdb27ddb7e242fcf4caf00 (diff)
downloadtk-672ad30f66fb7d68caca7ccfd50dfa6abfc551d2.zip
tk-672ad30f66fb7d68caca7ccfd50dfa6abfc551d2.tar.gz
tk-672ad30f66fb7d68caca7ccfd50dfa6abfc551d2.tar.bz2
Provide fallback for _strtoi64
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index f7b0f33..f6f71ca 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -110,8 +110,20 @@ SC_CONFIG_CFLAGS
AC_CHECK_HEADER(errno.h, , MAN2TCLFLAGS="-DNO_ERRNO_H")
AC_SUBST(MAN2TCLFLAGS)
+#-------------------------------------------
+# Check for _strtoi64
+#-------------------------------------------
+
+AC_CACHE_CHECK([availability of _strtoi64], tcl_have_strtoi64, [
+ AC_TRY_LINK([#include <stdlib.h>],
+ [_strtoi64(0,0,0)],
+ tcl_have_strtoi64=yes, tcl_have_strtoi64=no)])
+if test $tcl_have_strtoi64 = no; then
+ AC_DEFINE(NO_STRTOI64, 1, [Is _strtoi64 function available?])
+fi
+
#--------------------------------------------------------------------
-# Set the default compiler switches based on the --enable-symbols
+# Set the default compiler switches based on the --enable-symbols
# option. This macro depends on C flags, and should be called
# after SC_CONFIG_CFLAGS macro is called.
#--------------------------------------------------------------------