summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2002-11-06 10:49:59 (GMT)
committermdejong <mdejong>2002-11-06 10:49:59 (GMT)
commit75c1894c38b9bce91f9a95eb42011de24c5e7b42 (patch)
treea2c9620903056730d96b40bedbabf60692acb520 /win/configure.in
parent5efb972739e1035f9a910dc0206079818b052ba1 (diff)
downloadtk-75c1894c38b9bce91f9a95eb42011de24c5e7b42.zip
tk-75c1894c38b9bce91f9a95eb42011de24c5e7b42.tar.gz
tk-75c1894c38b9bce91f9a95eb42011de24c5e7b42.tar.bz2
* unix/configure: Regen.
* unix/tcl.m4: Update from Tcl. * win/configure: Regen. * win/configure.in: Check that AR, RANLIB, and RC are found on the path when building with gcc.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in18
1 files changed, 14 insertions, 4 deletions
diff --git a/win/configure.in b/win/configure.in
index e03a74a..846d8f9 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.47 2002/09/27 18:09:53 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.48 2002/11/06 10:49:59 mdejong Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -45,14 +45,24 @@ AC_PROG_CC
# autoconf 2.50. You can also just set
# the CC, AR, RANLIB, and RC environment
# variables if you want to cross compile.
-#AC_CHECK_TOOL(AR, ar, :)
-#AC_CHECK_TOOL(RANLIB, ranlib, :)
-#AC_CHECK_TOOL(RC, windres, :)
+#AC_CHECK_TOOL(AR, ar)
+#AC_CHECK_TOOL(RANLIB, ranlib)
+#AC_CHECK_TOOL(RC, windres)
if test "${GCC}" = "yes" ; then
AC_CHECK_PROG(AR, ar, ar)
AC_CHECK_PROG(RANLIB, ranlib, ranlib)
AC_CHECK_PROG(RC, windres, windres)
+
+ if test "${AR}" = "" ; then
+ AC_MSG_ERROR([Required archive tool 'ar' not found on PATH.])
+ fi
+ if test "${RANLIB}" = "" ; then
+ AC_MSG_ERROR([Required archive index tool 'ranlib' not found on PATH.])
+ fi
+ if test "${RC}" = "" ; then
+ AC_MSG_ERROR([Required resource tool 'windres' not found on PATH.])
+ fi
fi
#--------------------------------------------------------------------