summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2013-03-27 11:58:20 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2013-03-27 11:58:20 (GMT)
commit729820db14607dca8ab6a8185bef5928b8bbed6f (patch)
tree2398fdd617e2e98ab71885b07c48a1b3418f1cb0 /win/configure.in
parent848a0b0986e95d797bcbb1f50240f345a9c2d9a9 (diff)
parentbe9d4efe7ba6f645e1cd3e8c93dfa13f634eb972 (diff)
downloadtk-729820db14607dca8ab6a8185bef5928b8bbed6f.zip
tk-729820db14607dca8ab6a8185bef5928b8bbed6f.tar.gz
tk-729820db14607dca8ab6a8185bef5928b8bbed6f.tar.bz2
[Bug 3608074]: Add <<Invoke>> bindings to Button's, Listbox and Menu.
Document <<Invoke>>, <<ThemeChanged>>, <<EnteredChild>> (ttk_pandedwindow only) and <<Increment/Decrement>> (ttk_spinbox only)
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index d411aff..709e64e 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -81,6 +81,17 @@ SC_ENABLE_SHARED
SC_PATH_TCLCONFIG($TK_PATCH_LEVEL)
SC_LOAD_TCLCONFIG
+if test "${TCL_MAJOR_VERSION}" != "${TK_MAJOR_VERSION}"; then
+ AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+fi
+if test "${TCL_MINOR_VERSION}" -lt "${TK_MINOR_VERSION}"; then
+ AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+fi
+
#--------------------------------------------------------------------
# The statements below define a collection of compile flags. This
# macro depends on the value of SHARED_BUILD, and should be called