summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2020-12-22 14:28:55 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2020-12-22 14:28:55 (GMT)
commitaa74f8e4da395de0ffc09489cc0e8945d54a6534 (patch)
treeb14435a27384854ede58d23ac8a2686dea0950de /win/configure.in
parentf842b3719b0217887e9d078d7990bbaf6d3e5334 (diff)
downloadtk-aa74f8e4da395de0ffc09489cc0e8945d54a6534.zip
tk-aa74f8e4da395de0ffc09489cc0e8945d54a6534.tar.gz
tk-aa74f8e4da395de0ffc09489cc0e8945d54a6534.tar.bz2
Update all configure-related stuff to work with autoconf-2.70 too. For now, everything still generated with (modified) autoconf-2.59
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in14
1 files changed, 10 insertions, 4 deletions
diff --git a/win/configure.in b/win/configure.in
index ead30e3..3e7fa8d 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,8 +3,9 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
-AC_INIT(../generic/tk.h)
-AC_PREREQ(2.59)
+AC_INIT
+AC_CONFIG_SRCDIR([../generic/tk.h])
+AC_PREREQ([2.59])
# The following define is needed when building with Cygwin since newer
# versions of autoconf incorrectly set SHELL to /bin/bash instead of
@@ -89,6 +90,10 @@ SC_LOAD_TCLCONFIG
SC_CONFIG_CFLAGS
+AC_CHECK_TYPES([intptr_t, uintptr_t],,,[[
+#include <stdint.h>
+]])
+
#--------------------------------------------------------------------
# man2tcl needs this so that it can use errno.h
#--------------------------------------------------------------------
@@ -103,7 +108,7 @@ AC_SUBST(MAN2TCLFLAGS)
AC_CACHE_CHECK([availability of _strtoi64], tcl_cv_strtoi64, [
AC_TRY_LINK([#include <stdlib.h>],
[_strtoi64(0,0,0)],
- tcl_cv_strtoi64=yes, tcl_cv_strtoi64=no)])
+ [tcl_cv_strtoi64=yes],[tcl_cv_strtoi64=no])])
if test $tcl_cv_strtoi64 = no; then
AC_DEFINE(NO_STRTOI64, 1, [Is _strtoi64 function available?])
fi
@@ -291,7 +296,8 @@ AC_SUBST(TK_BUILD_STUB_LIB_PATH)
AC_SUBST(TK_CC_SEARCH_FLAGS)
AC_SUBST(TK_LD_SEARCH_FLAGS)
-AC_OUTPUT([Makefile tkConfig.sh wish.exe.manifest])
+AC_CONFIG_FILES([Makefile tkConfig.sh wish.exe.manifest])
+AC_OUTPUT
dnl Local Variables:
dnl mode: autoconf;