summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2008-06-13 21:48:35 (GMT)
committerhobbs <hobbs>2008-06-13 21:48:35 (GMT)
commit97adda8abbf04c68397fb636005a3a871f0b914c (patch)
tree98249a46bf4db6df9495fa9d4c522aa01aac5b2a /win/configure.in
parentf68e78c668f0a3077f3ddf8235a4359f43a68363 (diff)
downloadtk-97adda8abbf04c68397fb636005a3a871f0b914c.zip
tk-97adda8abbf04c68397fb636005a3a871f0b914c.tar.gz
tk-97adda8abbf04c68397fb636005a3a871f0b914c.tar.bz2
improve handling of various versions for patchlevel to winversion conversion
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/win/configure.in b/win/configure.in
index 7d908a3..184d537 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.77.2.2 2008/06/13 21:29:29 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.77.2.3 2008/06/13 21:48:35 hobbs Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.59)
@@ -230,13 +230,14 @@ else
fi
# The wish.exe.manifest requires these
-# TK_WIN_VERSION is the 4 dotted pair Windows version format
-# Make sure the patch level doesn't contain extra dotted pairs (interim rel)
+# TK_WIN_VERSION is the 4 dotted pair Windows version format which needs
+# the release level, and must account for interim release versioning
case "$TK_PATCH_LEVEL" in
- .[[0-9]]a*) TK_WIN_VERSION="$TK_VERSION.0`echo $TK_PATCH_LEVEL | tr -d a`" ;;
- .[[0-9]]b*) TK_WIN_VERSION="$TK_VERSION.1`echo $TK_PATCH_LEVEL | tr -d b`" ;;
- *) TK_WIN_VERSION="$TK_VERSION.2$TK_PATCH_LEVEL" ;;
+ *a*) TK_RELEASE_LEVEL=0 ;;
+ *b*) TK_RELEASE_LEVEL=1 ;;
+ *) TK_RELEASE_LEVEL=2 ;;
esac
+TK_WIN_VERSION="$TK_VERSION.$TK_RELEASE_LEVEL.`echo $TK_PATCH_LEVEL | tr -d ab.`"
AC_SUBST(TK_WIN_VERSION)
# X86|AMD64|IA64 for manifest
AC_SUBST(MACHINE)