summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2012-03-30 15:12:06 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2012-03-30 15:12:06 (GMT)
commit82f09d74956b7cd53fb289d631cd52b2a595da96 (patch)
tree550831700714e0ace7a604f0bf0ecde89410f223 /win/configure.in
parentb0f6c7757ff6565314d49f69fe45427c6bbda8d7 (diff)
parent49df110769eec89b42d4f354d37bc4762b2d07de (diff)
downloadtk-82f09d74956b7cd53fb289d631cd52b2a595da96.zip
tk-82f09d74956b7cd53fb289d631cd52b2a595da96.tar.gz
tk-82f09d74956b7cd53fb289d631cd52b2a595da96.tar.bz2
[Bug 3511806] Compiler checks too early
(autoconf still to be run!)
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in32
1 files changed, 3 insertions, 29 deletions
diff --git a/win/configure.in b/win/configure.in
index 7570b17..65f287a 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -55,32 +55,6 @@ AC_CHECK_TOOL(RC, windres)
AC_PROG_MAKE_SET
#--------------------------------------------------------------------
-# Perform additinal compiler tests.
-#--------------------------------------------------------------------
-
-dnl Currently AC_CYGWIN is disabled since it invokes AC_CANONICAL_HOST
-dnl under autoconf 2.5X.
-dnl
-dnl AC_CYGWIN
-
-AC_CACHE_CHECK(for Cygwin version of gcc,
- ac_cv_cygwin,
-AC_TRY_COMPILE([
-#ifdef __CYGWIN__
-#error cygwin
-#endif
-],
-[],
- ac_cv_cygwin=no,
- ac_cv_cygwin=yes)
-)
-if test "$ac_cv_cygwin" = "yes" ; then
- AC_MSG_ERROR([Compiling under Cygwin is not currently supported.
-A maintainer for the Cygwin port of Tcl/Tk is needed. See the README
-file for information about building with Mingw.])
-fi
-
-#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)
#--------------------------------------------------------------------
@@ -119,11 +93,11 @@ AC_SUBST(MAN2TCLFLAGS)
# Check for _strtoi64
#-------------------------------------------
-AC_CACHE_CHECK([availability of _strtoi64], tcl_have_strtoi64, [
+AC_CACHE_CHECK([availability of _strtoi64], tcl_cv_strtoi64, [
AC_TRY_LINK([#include <stdlib.h>],
[_strtoi64(0,0,0)],
- tcl_have_strtoi64=yes, tcl_have_strtoi64=no)])
-if test $tcl_have_strtoi64 = no; then
+ tcl_cv_strtoi64=yes, tcl_cv_strtoi64=no)])
+if test $tcl_cv_strtoi64 = no; then
AC_DEFINE(NO_STRTOI64, 1, [Is _strtoi64 function available?])
fi