summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 45528da..53bbfd1 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -379,16 +379,19 @@ AC_ARG_ENABLE(shared,
if test "$ok" = "yes" -a "${SHLIB_SUFFIX}" != ""; then
TK_SHARED_BUILD=1
TK_SHLIB_CFLAGS="${SHLIB_CFLAGS}"
- eval "TK_LIB_FILE=libtk${TCL_SHARED_LIB_SUFFIX}"
+ TK_LIB_FILE=libtk${TCL_SHARED_LIB_SUFFIX}
MAKE_LIB="\${SHLIB_LD} -o \${TK_LIB_FILE} \${OBJS} \$(TK_LD_SEARCH_FLAGS) ${SHLIB_LD_LIBS}"
RANLIB=":"
else
TK_SHARED_BUILD=0
TK_SHLIB_CFLAGS=""
- eval "TK_LIB_FILE=libtk${TCL_UNSHARED_LIB_SUFFIX}"
+ TK_LIB_FILE=libtk${TCL_UNSHARED_LIB_SUFFIX}
MAKE_LIB="ar cr \${TK_LIB_FILE} \${OBJS}"
fi
+DBGX='${TK_DBGX}'
+eval "TK_LIB_FILE=${TK_LIB_FILE}"
+
# Note: in the following variable, it's important to use the absolute
# path name of the Tcl directory rather than "..": this is because
# AIX remembers this path and will attempt to use it at run-time to look
@@ -399,8 +402,8 @@ if test "${TCL_LIB_VERSIONS_OK}" = "ok"; then
else
TK_LIB_FLAG="-ltk`echo ${VERSION} | tr -d .`\${TK_DBGX}"
fi
-TK_BUILD_LIB_SPEC="-L`pwd` \${TK_LIB_FLAG}"
-TK_LIB_SPEC="-L${exec_prefix}/lib \${TK_LIB_FLAG}"
+TK_BUILD_LIB_SPEC="-L`pwd` ${TK_LIB_FLAG}"
+TK_LIB_SPEC="-L${exec_prefix}/lib ${TK_LIB_FLAG}"
AC_SUBST(CFLAGS_DEBUG)
AC_SUBST(CFLAGS_DEFAULT)