summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index bc22472..7339983 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -592,7 +592,7 @@ fi
# Check whether XKeycodeToKeysym is deprecated in X11 headers.
#--------------------------------------------------------------------
-if test $tk_aqua = no; then
+if test $tk_aqua = no && test "$GCC" = yes; then
AC_MSG_CHECKING([whether XKeycodeToKeysym is deprecated])
tk_oldCFlags=$CFLAGS
CFLAGS="$CFLAGS -Werror"
@@ -601,9 +601,11 @@ if test $tk_aqua = no; then
], [
XKeycodeToKeysym(0,0,0);
], [
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([no])
+ ], [
+ AC_MSG_RESULT([yes])
AC_DEFINE(XKEYCODETOKEYSYM_IS_DEPRECATED, 1, [Is XKeycodeToKeysym deprecated?])
- ], AC_MSG_RESULT([no]))
+ ])
CFLAGS=$tk_oldCFlags
fi