summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in25
1 files changed, 24 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 7dbf335..732b301 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.104 2005/05/26 11:19:04 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.105 2005/05/27 23:14:29 dkf Exp $
AC_INIT([tk],[8.5])
AC_PREREQ(2.57)
@@ -323,6 +323,29 @@ if test -d /usr/include/mit ; then
fi
#--------------------------------------------------------------------
+# Check whether the header and library for the XScreenSaver
+# extension are available, and set HAVE_XSS if so.
+# XScreenSaver is needed for Tk_GetUserInactiveTime().
+#--------------------------------------------------------------------
+AC_MSG_CHECKING([for XScreenSaver support])
+tk_oldCFlags=$CFLAGS
+CFLAGS="$CFLAGS $XINCLUDES"
+tk_oldLibs=$LIBS
+LIBS="$LIBS $XLIBSW -lXss -lXext"
+AC_TRY_LINK([
+ #include <X11/Xlib.h>
+ #include <X11/extensions/scrnsaver.h>
+] , [
+ XScreenSaverAllocInfo();
+], [
+ AC_MSG_RESULT(yes)
+ XLIBSW="$XLIBSW -lXss -lXext"
+ AC_DEFINE([HAVE_XSS])
+], AC_MSG_RESULT(no))
+CFLAGS=$tk_oldCFlags
+LIBS=$tk_oldLibs
+
+#--------------------------------------------------------------------
# Check for freetype / fontconfig / Xft support.
#--------------------------------------------------------------------