summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in34
1 files changed, 33 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 01feb46..e1d74ea 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.86 2003/04/04 19:29:48 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.87 2003/05/31 18:32:21 jenglish Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.57)
@@ -282,6 +282,38 @@ if test -d /usr/include/mit ; then
fi
#--------------------------------------------------------------------
+# Check for freetype / fontconfig / Xft support.
+#--------------------------------------------------------------------
+
+AC_ARG_ENABLE(xft,
+ [ --enable-xft Use freetype/fontconfig/xft [--disable-xft]],
+ [enable_xft=$enableval],
+ [enable_xft="no"])
+
+XFT_CFLAGS=""
+XFT_LIBS=""
+if test "$enable_xft" = "yes" ; then
+ AC_MSG_CHECKING([for xft configuration])
+ XFT_CFLAGS=`pkg-config --cflags xft` || enable_xft="no"
+ XFT_LIBS=`pkg-config --libs xft` || enable_xft="no"
+ if test "$enable_xft" = "yes" ; then
+ AC_MSG_RESULT([ok])
+ else
+ AC_MSG_WARN([Can't find xft configuration])
+ fi
+fi
+if test enable_xft="yes" ; then
+ UNIX_FONT_OBJS=tkUnixRFont.o
+ AC_DEFINE(HAVE_XFT)
+else
+ UNIX_FONT_OBJS=tkUnixFont.o
+fi
+
+AC_SUBST(XFT_CFLAGS)
+AC_SUBST(XFT_LIBS)
+AC_SUBST(UNIX_FONT_OBJS)
+
+#--------------------------------------------------------------------
# Figure out whether "char" is unsigned. If so, set a
# #define for __CHAR_UNSIGNED__.
#--------------------------------------------------------------------