summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in31
1 files changed, 6 insertions, 25 deletions
diff --git a/unix/configure.in b/unix/configure.in
index f79b4db..99b37c1 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tk.h)
-# RCS: @(#) $Id: configure.in,v 1.28 1999/03/10 07:04:45 stanton Exp $
+# RCS: @(#) $Id: configure.in,v 1.29 1999/03/22 21:32:16 redman Exp $
TK_VERSION=8.0
TK_MAJOR_VERSION=8
@@ -449,31 +449,12 @@ fi
# using tcl stub support.
#--------------------------------------------------------------------
-AC_MSG_CHECKING(how to link to Tcl)
+# Linking to the Tcl stub library is not supported until Tk is a fully
+# loadable extension.
-AC_ARG_ENABLE(tcl-stub,
- [ --enable-tcl-stub use the Tcl stub interface],
- [tk_ok=$enableval], [tk_ok=no])
-
-if test "$tk_ok" = "yes" ; then
-
- AC_MSG_RESULT(using Tcl stub interface)
-
- TCL_STUB_FLAGS="-DUSE_TCL_STUBS"
-
- # Don't link Tk directly to Tcl.
-
- if test "$SHLIB_LD_LIBS" = '${LIBS}'; then
- SHLIB_LD_LIBS='${STUB_LIBS}'
- else
- SHLIB_LD_LIBS="${SHLIB_LD_LIBS} \${TCL_BUILD_STUB_LIB_SPEC}"
- fi
-else
- AC_MSG_RESULT(dynamic linking)
-
- TCL_BUILD_STUB_LIB_SPEC=""
- TCL_STUB_FLAGS=""
-fi
+AC_MSG_RESULT(dynamic linking)
+TCL_BUILD_STUB_LIB_SPEC=""
+TCL_STUB_FLAGS=""
#--------------------------------------------------------------------
# The statements below define various symbols relating to Tcl