summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 8182d93..590b70d 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.120 2006/07/20 06:25:20 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.121 2006/08/18 07:47:11 das Exp $
AC_INIT([tk],[8.5])
AC_PREREQ(2.59)
@@ -257,11 +257,10 @@ if test "`uname -s`" = "Darwin" ; then
fi
fi
AC_MSG_RESULT([$tk_aqua])
- if test $do64bit_ok = no ; then
- # remove -arch ppc64 from CFLAGS for fat builds as neither Aqua nor X11
- # can be built for 64bit at present (no 64bit GUI libraries).
- CFLAGS="`echo "$CFLAGS" | sed -e 's/-arch ppc64/-arch ppc/g'`"
- fi
+ # remove 64-bit arch flags from CFLAGS for combined 32-bit and 64-bit fat
+ # builds, as neither TkAqua nor TkX11 can be built for 64-bit at present.
+ test "$fat_32_64" = yes && \
+ CFLAGS="`echo "$CFLAGS " | sed -e 's/-arch ppc64 / /g' -e 's/-arch x86_64 / /g'`"
if test $tk_aqua = no; then
# check if weak linking whole libraries is possible.
AC_CACHE_CHECK([if ld accepts -weak-l flag], tcl_cv_ld_weak_l, [