summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in33
1 files changed, 14 insertions, 19 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 486a0c2..47b6942 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83.2.25 2005/11/27 04:23:39 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.83.2.26 2006/01/10 05:38:40 das Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -48,6 +48,7 @@ TK_SRC_DIR=`cd $srcdir/..; pwd`
#------------------------------------------------------------------------
# Compress and/or soft link the manpages?
#------------------------------------------------------------------------
+
SC_CONFIG_MANPAGES([tk])
#------------------------------------------------------------------------
@@ -80,7 +81,7 @@ AC_EGREP_HEADER(strtod, stdlib.h, , tk_ok=no)
if test $tk_ok = no; then
AC_DEFINE(NO_STDLIB_H)
fi
-AC_MSG_RESULT($tk_ok)
+AC_MSG_RESULT([$tk_ok])
#------------------------------------------------------------------------
# If we're using GCC, see if the compiler understands -pipe. If so, use it.
@@ -93,9 +94,9 @@ if test -n "$GCC"; then
OLDCC="$CC"
CC="$CC -pipe"
AC_TRY_COMPILE(,,
- AC_MSG_RESULT(yes),
+ AC_MSG_RESULT([yes]),
CC="$OLDCC"
- AC_MSG_RESULT(no))
+ AC_MSG_RESULT([no]))
fi
fi
@@ -174,18 +175,14 @@ fi
# special flag.
#--------------------------------------------------------------------
-AC_MSG_CHECKING([for fd_set in sys/types])
-AC_CACHE_VAL(tcl_cv_type_fd_set,
+AC_CACHE_CHECK([for fd_set in sys/types], tcl_cv_type_fd_set,
AC_TRY_COMPILE([#include <sys/types.h>],[fd_set readMask, writeMask;],
tcl_cv_type_fd_set=yes, tcl_cv_type_fd_set=no))
-AC_MSG_RESULT($tcl_cv_type_fd_set)
tk_ok=$tcl_cv_type_fd_set
-if test $tcl_cv_type_fd_set = no; then
- AC_MSG_CHECKING([for fd_mask in sys/select])
- AC_CACHE_VAL(tcl_cv_grep_fd_mask,
+if test $tk_ok = no; then
+ AC_CACHE_CHECK([for fd_mask in sys/select], tcl_cv_grep_fd_mask,
AC_EGREP_HEADER(fd_mask, sys/select.h,
tcl_cv_grep_fd_mask=present, tcl_cv_grep_fd_mask=missing))
- AC_MSG_RESULT($tcl_cv_grep_fd_mask)
if test $tcl_cv_grep_fd_mask = present; then
AC_DEFINE(HAVE_SYS_SELECT_H)
tk_ok=yes
@@ -225,12 +222,10 @@ AC_TYPE_UID_T
# In OS/390 struct pwd has no pw_gecos field
#-------------------------------------------
-AC_MSG_CHECKING([pw_gecos in struct pwd])
-AC_CACHE_VAL(tcl_cv_pwd_pw_gecos,
+AC_CACHE_CHECK([pw_gecos in struct pwd], tcl_cv_pwd_pw_gecos,
AC_TRY_COMPILE([#include <pwd.h>],
[struct passwd pwd; pwd.pw_gecos;],
tcl_cv_pwd_pw_gecos=yes, tcl_cv_pwd_pw_gecos=no))
-AC_MSG_RESULT($tcl_cv_pwd_pw_gecos)
if test $tcl_cv_pwd_pw_gecos = yes; then
AC_DEFINE(HAVE_PW_GECOS)
fi
@@ -244,10 +239,10 @@ if test "`uname -s`" = "Darwin" ; then
[tk_aqua=$enableval], [tk_aqua=no])
if test $tk_aqua = yes; then
if test $tcl_corefoundation = no; then
- AC_MSG_WARN("Aqua can only be used when CoreFoundation is available")
+ AC_MSG_WARN([Aqua can only be used when CoreFoundation is available])
tk_aqua=no
elif test ! -d /System/Library/Frameworks/Carbon.framework; then
- AC_MSG_WARN("Aqua can only be used when Carbon is available")
+ AC_MSG_WARN([Aqua can only be used when Carbon is available])
tk_aqua=no
fi
fi
@@ -366,10 +361,10 @@ if test -d /usr/include/mit -a $tk_aqua = no; then
], [
XOpenDisplay(0);
], [
- AC_MSG_RESULT(yes)
+ AC_MSG_RESULT([yes])
XLIBSW="-lX11-mit"
XINCLUDES="-I/usr/include/mit"
- ], AC_MSG_RESULT(no))
+ ], AC_MSG_RESULT([no]))
CFLAGS=$tk_oldCFlags
LIBS=$tk_oldLibs
fi
@@ -501,7 +496,7 @@ if test $tk_aqua = yes; then
LIB_RSRC_FILE='${TK_RSRC_FILE}'
APP_RSRC_FILE='${WISH_RSRC_FILE}'
REZ=/Developer/Tools/Rez
- REZ_FLAGS='-d "SystemSevenOrLater=1" -useDF'
+ REZ_FLAGS='-d "SystemSevenOrLater=1" -useDF -ro'
if test "$SHARED_BUILD" = 0; then
EXTRA_INSTALL_BINARIES='@echo "Installing $(TK_RSRC_FILE) to $(LIB_INSTALL_DIR)" && $(INSTALL_DATA) $(TK_RSRC_FILE) $(LIB_INSTALL_DIR)'
TK_BUILD_LIB_SPEC="$TK_BUILD_LIB_SPEC -sectcreate __TEXT __tk_rsrc `pwd`/\${TK_RSRC_FILE}"