summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index f6f71ca..ffad2c0 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -114,6 +114,7 @@ AC_SUBST(MAN2TCLFLAGS)
# Check for _strtoi64
#-------------------------------------------
+if test "${MACHINE}" = "X86" ; then
AC_CACHE_CHECK([availability of _strtoi64], tcl_have_strtoi64, [
AC_TRY_LINK([#include <stdlib.h>],
[_strtoi64(0,0,0)],
@@ -121,6 +122,7 @@ AC_CACHE_CHECK([availability of _strtoi64], tcl_have_strtoi64, [
if test $tcl_have_strtoi64 = no; then
AC_DEFINE(NO_STRTOI64, 1, [Is _strtoi64 function available?])
fi
+fi
#--------------------------------------------------------------------
# Set the default compiler switches based on the --enable-symbols