summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in28
1 files changed, 17 insertions, 11 deletions
diff --git a/win/configure.in b/win/configure.in
index ae8398f..138e658 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -2,7 +2,7 @@
# generate the file "configure", which is run during Tk installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.29 2001/06/26 00:56:44 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.30 2001/06/26 20:17:22 mdejong Exp $
AC_INIT(../generic/tk.h)
@@ -27,6 +27,12 @@ fi
# Standard compiler checks
#------------------------------------------------------------------------
+# If the user did not set CFLAGS, set it now to keep
+# the AC_PROG_CC macro from adding "-g -O2".
+if test "${CFLAGS+set}" != "set" ; then
+ export CFLAGS=""
+fi
+
AC_PROG_CC
# To properly support cross-compilation, one would
@@ -35,15 +41,15 @@ AC_PROG_CC
# autoconf 2.50. You can also just set
# the CC, AR, RANLIB, and RC environment
# variables if you want to cross compile.
-#AC_CHECK_TOOL(AR, ar, :)
-#AC_CHECK_TOOL(RANLIB, ranlib, :)
-#AC_CHECK_TOOL(RC, windres, :)
-
-if test "${GCC}" = "yes" ; then
- AC_CHECK_PROG(AR, ar, ar)
- AC_CHECK_PROG(RANLIB, ranlib, ranlib)
- AC_CHECK_PROG(RC, windres, windres)
-fi
+AC_CHECK_TOOL(AR, ar, :)
+AC_CHECK_TOOL(RANLIB, ranlib, :)
+AC_CHECK_TOOL(RC, windres, :)
+
+dnl if test "${GCC}" = "yes" ; then
+ dnl AC_CHECK_PROG(AR, ar, ar)
+ dnl AC_CHECK_PROG(RANLIB, ranlib, ranlib)
+ dnl AC_CHECK_PROG(RC, windres, windres)
+dnl fi
#--------------------------------------------------------------------
# Checks to see if the make progeam sets the $MAKE variable.
@@ -55,7 +61,7 @@ AC_PROG_MAKE_SET
# These two macros perform additinal compiler test.
#--------------------------------------------------------------------
-AC_CYGWIN
+dnl AC_CYGWIN
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)