From cde3f5abce011188551a0ecf07930ff80631ef72 Mon Sep 17 00:00:00 2001
From: das <das>
Date: Fri, 10 Apr 2009 16:29:18 +0000
Subject: 	* library/console.tcl (::tk::ConsoleInit): remove redundant
 TkAqua 	Quit menu item.

---
 ChangeLog           | 3 +++
 library/console.tcl | 7 ++-----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/ChangeLog b/ChangeLog
index 237c7e4..ade45c0 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
 2008-04-10  Daniel Steffen  <das@users.sourceforge.net>
 
+	* library/console.tcl (::tk::ConsoleInit): remove redundant TkAqua
+	Quit menu item.
+
 	* generic/tkPointer.c (Tk_UpdatePointer): use all 5 buttons.
 
 	* generic/tkMenu.c (PostProcessEntry): delay call to
diff --git a/library/console.tcl b/library/console.tcl
index 7008c91..8d31e2a 100644
--- a/library/console.tcl
+++ b/library/console.tcl
@@ -4,7 +4,7 @@
 # can be used by non-unix systems that do not have built-in support
 # for shells.
 #
-# RCS: @(#) $Id: console.tcl,v 1.37.2.1 2009/01/30 21:06:05 patthoyts Exp $
+# RCS: @(#) $Id: console.tcl,v 1.37.2.2 2009/04/10 16:29:18 das Exp $
 #
 # Copyright (c) 1995-1997 Sun Microsystems, Inc.
 # Copyright (c) 1998-2000 Ajuba Solutions.
@@ -69,10 +69,7 @@ proc ::tk::ConsoleInit {} {
 	    -command {wm withdraw .}
     AmpMenuArgs .menubar.file add command -label [mc "&Clear Console"] \
 	    -command {.console delete 1.0 "promptEnd linestart"}
-    if {[tk windowingsystem] eq "aqua"} {
-	AmpMenuArgs .menubar.file add command \
-		-label [mc &Quit] -command {exit} -accel "Cmd-Q"
-    } else {
+    if {[tk windowingsystem] ne "aqua"} {
 	AmpMenuArgs .menubar.file add command -label [mc E&xit] -command {exit}
     }
 
-- 
cgit v0.12