summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-07-15 10:17:15 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-07-15 10:17:15 (GMT)
commit61439d49e15045bbe9c3cf55b62fc15909dd48e2 (patch)
tree6bfacf394b186226e0ba5308d8fcd735203e52a4 /CMakeLists.txt
parentdbd110e2b7eb08c65218a5f9d09ef12fdc62c04a (diff)
downloaduscxml-61439d49e15045bbe9c3cf55b62fc15909dd48e2.zip
uscxml-61439d49e15045bbe9c3cf55b62fc15909dd48e2.tar.gz
uscxml-61439d49e15045bbe9c3cf55b62fc15909dd48e2.tar.bz2
Improved support for dot output
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 16 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f016f98..cfe179c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,7 +164,7 @@ else ()
endif()
endif()
-SET(USCXML_LIBRARY_HOST_URL_PREFIX "http://uscxml.tk.informatik.tu-darmstadt.de/prebuilt" CACHE STRING "The root path of an URL where to look for prebuilt libraries.")
+SET(USCXML_LIBRARY_HOST_URL_PREFIX "http://uscxml.mintwerk.de/prebuilt" CACHE STRING "The root path of an URL where to look for prebuilt libraries.")
if (CMAKE_CROSSCOMPILING)
if (IOS)
@@ -306,6 +306,7 @@ else()
OPTION(BUILD_TESTS "Build USCXML tests" ON)
OPTION(BUILD_TESTS_W3C_ECMA "Create W3C ECMAScript tests" ON)
OPTION(BUILD_TESTS_W3C_XPATH "Create W3C XPath tests" ON)
+ OPTION(BUILD_TESTS_W3C_LUA "Create W3C Lua tests" ON)
OPTION(BUILD_TESTS_FSM_ECMA "Create FSM converted W3C ECMAScript tests" OFF)
OPTION(BUILD_TESTS_FSM_XPATH "Create FSM converted W3C XPath tests" OFF)
endif()
@@ -1041,6 +1042,20 @@ if (NOT CMAKE_CROSSCOMPILING)
set_target_properties(uscxml-transform PROPERTIES FOLDER "Apps")
install_executable(TARGETS uscxml-transform COMPONENT tools)
+ if (WIN32)
+ add_executable(uscxml-dot apps/uscxml-dot.cpp ${PROJECT_SOURCE_DIR}/contrib/src/getopt/getopt.c)
+ else()
+ add_executable(uscxml-dot apps/uscxml-dot.cpp)
+ endif()
+ target_link_libraries(uscxml-dot uscxml)
+ if (NOT CMAKE_CROSSCOMPILING)
+ if (ENABLE_COTIRE)
+ set_target_properties(uscxml-dot PROPERTIES COTIRE_ADD_UNITY_BUILD FALSE)
+ endif()
+ endif()
+ set_target_properties(uscxml-dot PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-dot COMPONENT tools)
+
if (PROTOBUF_FOUND AND OFF)
file(GLOB W3C-MMI-COMMON ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.h)