summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2016-12-24 10:54:21 (GMT)
committerStefan Radomski <github@mintwerk.de>2016-12-24 10:54:21 (GMT)
commitcbb57aadbfe11269297c36f578d4a440a3602436 (patch)
treeccfd08eb9104d9bd142f1e7417fc0ed95f57f77f /CMakeLists.txt
parent75fc3b465fb3d61d36874cf7a29ddbb8256e3817 (diff)
downloaduscxml-cbb57aadbfe11269297c36f578d4a440a3602436.zip
uscxml-cbb57aadbfe11269297c36f578d4a440a3602436.tar.gz
uscxml-cbb57aadbfe11269297c36f578d4a440a3602436.tar.bz2
First implementation of Python wrappers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index acea546..11a391c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,6 +199,7 @@ endif()
OPTION(BUILD_BINDING_JAVA "Build language bindings for Java" ON)
OPTION(BUILD_BINDING_LUA "Build language bindings for Lua" ON)
OPTION(BUILD_BINDING_CSHARP "Build language bindings for CSharp" ON)
+OPTION(BUILD_BINDING_PYTHON "Build language bindings for Python" ON)
OPTION(BUILD_BINDING_PHP "Build language bindings for PHP" OFF)
@@ -371,6 +372,18 @@ if (WITH_DM_LUA)
endif()
endif()
+# Python
+OPTION(WITH_DM_PYTHON "Do search for the Python libraries" ON)
+if (WITH_DM_PYTHON)
+ find_package(PythonLibs)
+ if (PYTHONLIBS_FOUND)
+ include_directories (${PYTHON_INCLUDE_DIRS})
+ list (APPEND USCXML_OPT_LIBS ${PYTHON_LIBRARIES})
+ else()
+ set(WITH_DM_PYTHON ON)
+ endif()
+endif()
+
OPTION(WITH_DM_C89 "Do build with C89 datamodel support" OFF)
if (WITH_DM_C89)
include("${CMAKE_MODULE_PATH}/BuildPicoC.cmake")