summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-06 21:17:13 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-06 21:17:13 (GMT)
commit1e6ba139ac12c688f025745812d381915775b1fb (patch)
tree1d49070eddd4502ec6aa25a769ab7c47d04a1c30 /CMakeLists.txt
parent139439f0675ec05e936fd4297086462037cd618e (diff)
downloaduscxml-1e6ba139ac12c688f025745812d381915775b1fb.zip
uscxml-1e6ba139ac12c688f025745812d381915775b1fb.tar.gz
uscxml-1e6ba139ac12c688f025745812d381915775b1fb.tar.bz2
See detailled log
Added new revised W3C tests Hide Interpreter via PIMPL Implemented SCXMLIOProcessor
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 22 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf59195..87f6ef8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -459,19 +459,37 @@ endif()
# LIBEVENT basichttp ioprocessor - this one is already required above
-file(GLOB_RECURSE LIBEVENT_IOPROCESSOR
+file(GLOB_RECURSE BASICHTTP_IOPROCESSOR
src/uscxml/plugins/ioprocessor/basichttp/*.cpp
src/uscxml/plugins/ioprocessor/basichttp/*.h
)
-source_group("IOProcessor\\basichttp" FILES ${LIBEVENT_IOPROCESSOR})
+source_group("IOProcessor\\basichttp" FILES ${BASICHTTP_IOPROCESSOR})
if (BUILD_AS_PLUGINS)
add_library(
ioprocessor_basichttp SHARED
- ${LIBEVENT_IOPROCESSOR})
+ ${BASICHTTP_IOPROCESSOR})
target_link_libraries(ioprocessor_basichttp uscxml)
set_target_properties(ioprocessor_basichttp PROPERTIES FOLDER "Plugin IOProcessor")
else()
- list (APPEND USCXML_FILES ${LIBEVENT_IOPROCESSOR})
+ list (APPEND USCXML_FILES ${BASICHTTP_IOPROCESSOR})
+endif()
+
+
+# scxml ioprocessor - this one is already required above
+
+file(GLOB_RECURSE SCXML_IOPROCESSOR
+ src/uscxml/plugins/ioprocessor/scxml/*.cpp
+ src/uscxml/plugins/ioprocessor/scxml/*.h
+)
+source_group("IOProcessor\\scxml" FILES ${SCXML_IOPROCESSOR})
+if (BUILD_AS_PLUGINS)
+ add_library(
+ ioprocessor_scxml SHARED
+ ${SCXML_IOPROCESSOR})
+ target_link_libraries(ioprocessor_scxml uscxml)
+ set_target_properties(ioprocessor_scxml PROPERTIES FOLDER "Plugin IOProcessor")
+else()
+ list (APPEND USCXML_FILES ${SCXML_IOPROCESSOR})
endif()