summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-14 10:29:14 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-14 10:29:14 (GMT)
commit631b88e42c3fb7e10dee390d170854e40c31fac0 (patch)
tree06d970c489848e65d9c27eb464674f9e1cfa0348 /CMakeLists.txt
parent01e7e16d34b23b1198455809860abe4e43d9606a (diff)
downloaduscxml-631b88e42c3fb7e10dee390d170854e40c31fac0.zip
uscxml-631b88e42c3fb7e10dee390d170854e40c31fac0.tar.gz
uscxml-631b88e42c3fb7e10dee390d170854e40c31fac0.tar.bz2
Fixed vrml-server and added conditional for gcov
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fea1b5b..62c865d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -149,6 +149,7 @@ else()
OPTION(BUILD_TESTS "Build USCXML tests" ON)
OPTION(RUN_W3C_TESTS "Run W3C tests" ON)
endif()
+OPTION(ENABLE_GCOV "Compile with gcov support" OFF)
# a dummy target to depend on the targets needed for tests, see:
# http://stackoverflow.com/questions/733475/cmake-ctest-make-test-doesnt-build-tests
@@ -185,7 +186,7 @@ if(${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU")
add_definitions(-fPIC)
add_definitions(-Wunreachable-code)
- if (CMAKE_BUILD_TYPE MATCHES ".*Deb.*") # when not building for debug
+ if (CMAKE_BUILD_TYPE MATCHES ".*Deb.*" AND ENABLE_GCOV) # when not building for debug
# coverage information
add_definitions(-fprofile-arcs)
add_definitions(-ftest-coverage)