summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-03-22 13:32:20 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-03-22 13:32:20 (GMT)
commit75c3239c820cfbd7c903cb30de06aebab112e4c2 (patch)
tree9a7eed459a1950714b8ec5ca3b379156b46452b8 /CMakeLists.txt
parentdbc9a01b53cf5d069a176f47d24de81c1c5efd69 (diff)
downloaduscxml-75c3239c820cfbd7c903cb30de06aebab112e4c2.zip
uscxml-75c3239c820cfbd7c903cb30de06aebab112e4c2.tar.gz
uscxml-75c3239c820cfbd7c903cb30de06aebab112e4c2.tar.bz2
Some minor bugfixes
- Disabled peer verification with ssl URLs - Fixed a buffer overrun with JSON parsing - Changed test.php url to github
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a10872..e6a3d61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -353,10 +353,16 @@ include_directories(${Boost_INCLUDE_DIR})
# CURL
-
find_package(CURL REQUIRED)
+find_package(OpenSSL REQUIRED)
+find_package(ZLIB REQUIRED)
+
+include_directories(${OPENSSL_INCLUDE_DIR})
+include_directories(${ZLIB_INCLUDE_DIRS})
include_directories(${CURL_INCLUDE_DIRS})
list (APPEND USCXML_CORE_LIBS ${CURL_LIBRARIES})
+list (APPEND USCXML_CORE_LIBS ${OPENSSL_LIBRARIES})
+list (APPEND USCXML_CORE_LIBS ${ZLIB_LIBRARIES})
if (WIN32)
add_definitions("-DCURL_STATICLIB")
endif()