summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2012-12-27 21:17:45 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2012-12-27 21:17:45 (GMT)
commit7b8da7c5b88714f8b4892c83703c16b19a6cb80d (patch)
tree9f78c6399274a937c662454d51ab4314ad9ec903 /CMakeLists.txt
parentfa05389f050004a14787cd7b4ebb6e0b54e0e4af (diff)
downloaduscxml-7b8da7c5b88714f8b4892c83703c16b19a6cb80d.zip
uscxml-7b8da7c5b88714f8b4892c83703c16b19a6cb80d.tar.gz
uscxml-7b8da7c5b88714f8b4892c83703c16b19a6cb80d.tar.bz2
New scenegraph invoker using OpenSceneGraph
Ultimately, the scenegraph invoker ought to use x3d
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6ce335..31fb7c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -520,8 +520,9 @@ endif()
# OpenSceneGraph invoker
-find_package(OpenSceneGraph)
+find_package(OpenSceneGraph COMPONENTS osgDB osgGA osgUtil osgText osgFX osgManipulator osgViewer OpenThreads)
if (OPENSCENEGRAPH_FOUND)
+ include_directories(${OPENSCENEGRAPH_INCLUDE_DIRS})
file(GLOB_RECURSE OPENSCENEGRAPH_INVOKER
src/uscxml/plugins/invoker/graphics/openscenegraph/*.cpp
src/uscxml/plugins/invoker/graphics/openscenegraph/*.h)