summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-30 18:21:11 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-30 18:21:11 (GMT)
commit8544230e7902f2a204877dd9ed4dc8e6115be120 (patch)
tree2e34430b1dd2136391d442a5dfda6e9a4a148f12 /CMakeLists.txt
parentaa635ecc06213bfb7f4f6c62cbb8e99832d99d48 (diff)
downloaduscxml-8544230e7902f2a204877dd9ed4dc8e6115be120.zip
uscxml-8544230e7902f2a204877dd9ed4dc8e6115be120.tar.gz
uscxml-8544230e7902f2a204877dd9ed4dc8e6115be120.tar.bz2
Removed conditional SWIG compile and polished PHP API
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68b196a..8cdbb75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -327,6 +327,7 @@ if (NOT WIN32)
set(XML_LIBRARIES ${LIBXML2_LIBRARIES})
if (NOT APPLE)
list (APPEND USCXML_CORE_LIBS "rt")
+ list (APPEND USCXML_CORE_LIBS "rt") // yes it's needed twice e.g. on ubuntu
endif()
list (APPEND USCXML_CORE_LIBS "dl")
list (APPEND USCXML_CORE_LIBS "pthread")