summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-01-31 20:25:25 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-01-31 20:25:25 (GMT)
commit9be64debafa321a6712a9c500b36136757d588c7 (patch)
treed912892649f6d50559b545494fa225e1ea36a24e /CMakeLists.txt
parent3b321677e433dbc6f88c9e7faed0857022514efe (diff)
downloaduscxml-9be64debafa321a6712a9c500b36136757d588c7.zip
uscxml-9be64debafa321a6712a9c500b36136757d588c7.tar.gz
uscxml-9be64debafa321a6712a9c500b36136757d588c7.tar.bz2
Corrected configure-time check for SMTP in curl
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 382fa56..968e4d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -577,16 +577,12 @@ set(CMAKE_REQUIRED_LIBRARIES ${CURL_LIBRARIES})
check_cxx_source_compiles("
#include <curl/curl.h>
- int main(){return CURLOPT_MAIL_RCPT}
+ int main(){return CURLOPT_MAIL_RCPT; }
" CURL_HAS_SMTP)
set(CMAKE_REQUIRED_INCLUDES)
set(CMAKE_REQUIRED_LIBRARIES)
-if (NOT CURL_HAS_SMTP)
- message(STATUS "Curl missing SMTP support.")
-endif()
-
# GLOG
# set(ENV{GLOG_SRC} ${CMAKE_SOURCE_DIR}/../glog)
find_package(GLOG REQUIRED)