summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-03-07 13:03:04 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-03-07 13:03:04 (GMT)
commitca46aa711fb5d08a8fd1cc6b91593c281189e8e3 (patch)
treec46ed5fcbf44ea1a32517f8ba3d6d9a066b6fed8 /CMakeLists.txt
parentfce16e70dff8503bfab2e734bca5a52d9057a3ee (diff)
downloaduscxml-ca46aa711fb5d08a8fd1cc6b91593c281189e8e3.zip
uscxml-ca46aa711fb5d08a8fd1cc6b91593c281189e8e3.tar.gz
uscxml-ca46aa711fb5d08a8fd1cc6b91593c281189e8e3.tar.bz2
Modified InterpreterMonitor for uscxml-debugger
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index facfcd3..f1ba3bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -854,6 +854,7 @@ endif()
# Binaries and tests
############################################################
+list(SORT USCXML_FILES)
# we cannot use source groups in sub directories!
foreach( FILE ${USCXML_FILES} )
get_filename_component(PATH ${FILE} PATH)
@@ -889,6 +890,15 @@ foreach( FILE ${USCXML_FILES} )
# STRING(REGEX MATCH "[^\\/]*$" COMP_NAME ${PATH})
# source_group("Interpreter\\URL" FILES ${FILE})
+ elseif (${FILE} MATCHES ".*\\/debug\\/.*")
+ source_group("Interpreter\\debug" FILES ${FILE})
+ elseif (${FILE} MATCHES ".*\\/util\\/.*")
+ source_group("Interpreter\\util" FILES ${FILE})
+ elseif (${FILE} MATCHES ".*\\/concurrency\\/.*")
+ source_group("Interpreter\\concurrency" FILES ${FILE})
+ elseif (${FILE} MATCHES ".*\\/server\\/.*")
+ source_group("Interpreter\\server" FILES ${FILE})
+
else ()
source_group(Interpreter FILES ${FILE})
endif()