summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-11-16 00:44:33 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-11-16 00:44:33 (GMT)
commit69d34f5598974dddeab14e0fe9169108362622ec (patch)
tree17fbdbfc28dd11bc8852b697a262d63b9c76df38 /CMakeLists.txt
parentf33e8148fc6e214886a8b24fc9d743ee25da7d61 (diff)
downloaduscxml-69d34f5598974dddeab14e0fe9169108362622ec.zip
uscxml-69d34f5598974dddeab14e0fe9169108362622ec.tar.gz
uscxml-69d34f5598974dddeab14e0fe9169108362622ec.tar.bz2
WebSockets!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 32b1700..0454f4c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -254,6 +254,7 @@ if (WIN32)
include_directories(${PROJECT_SOURCE_DIR}/contrib/src/inttypes)
endif()
include_directories(${PROJECT_SOURCE_DIR}/contrib/src/jsmn)
+include_directories(${PROJECT_SOURCE_DIR}/contrib/src/evws)
#include_directories(${PROJECT_SOURCE_DIR}/contrib/src/google-url)
############################################################
@@ -913,7 +914,10 @@ endif()
# Header Files
############################################################
-file(GLOB_RECURSE USCXML_HEADERS ${PROJECT_SOURCE_DIR}/src/*.h ${CMAKE_BINARY_DIR}/*.h)
+file(GLOB_RECURSE USCXML_HEADERS
+ ${PROJECT_SOURCE_DIR}/src/*.h
+ ${PROJECT_SOURCE_DIR}/src/*.hpp
+ ${CMAKE_BINARY_DIR}/*.h)
INSTALL_HEADERS(HEADERS ${USCXML_HEADERS} COMPONENT headers)
############################################################