summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-08-21 11:19:08 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-08-21 11:19:08 (GMT)
commita3fb1daf5b4e58471cc714853636025b6cac9aed (patch)
tree03f60a2f396f7d339a0733099da0f56f64c8d822 /CMakeLists.txt
parent7454d99f1d02c68706da1ed6237a5f391291942d (diff)
downloaduscxml-a3fb1daf5b4e58471cc714853636025b6cac9aed.zip
uscxml-a3fb1daf5b4e58471cc714853636025b6cac9aed.tar.gz
uscxml-a3fb1daf5b4e58471cc714853636025b6cac9aed.tar.bz2
Reactiveted new CMake policies and some more documentation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11fc485..f702a67 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,13 +2,17 @@ cmake_minimum_required(VERSION 2.8.4)
cmake_policy(PUSH)
if(POLICY CMP0042)
- cmake_policy(SET CMP0042 OLD)
+ # new behavior defaults to ON for MACOSX_RPATH
+ cmake_policy(SET CMP0042 NEW)
endif()
if(POLICY CMP0045)
+ # Error on non-existent target in get_target_property,
+ # set to old as we actually use it to check for specific targets
cmake_policy(SET CMP0045 OLD)
endif()
if(POLICY CMP0046)
- cmake_policy(SET CMP0046 OLD)
+ # Error on non-existent dependency in add_dependencies
+ cmake_policy(SET CMP0046 NEW)
endif()
# specify USCXML version