summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2017-01-23 22:53:31 (GMT)
committerStefan Radomski <github@mintwerk.de>2017-01-23 22:53:31 (GMT)
commitb450411ee8f0a57f3ec3909d65ecc289189e2b35 (patch)
tree7051138495509431379a63fe16c1bbaaa41c9bc7 /CMakeLists.txt
parent24ac6c39a89f5b94ede80b745f68ea5f0b762640 (diff)
downloaduscxml-b450411ee8f0a57f3ec3909d65ecc289189e2b35.zip
uscxml-b450411ee8f0a57f3ec3909d65ecc289189e2b35.tar.gz
uscxml-b450411ee8f0a57f3ec3909d65ecc289189e2b35.tar.bz2
Added -Wall for clang and gcc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16bf183..a7c4cdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,10 +120,10 @@ elseif(COMPILER_SUPPORTS_CXX0X_FLAG)
endif()
if(${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic -Wall")
elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL Clang)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic -Wall")
elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL MSVC)
add_definitions("-D_SCL_SECURE_NO_WARNINGS")