summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2017-01-23 22:31:54 (GMT)
committerStefan Radomski <github@mintwerk.de>2017-01-23 22:31:54 (GMT)
commit24ac6c39a89f5b94ede80b745f68ea5f0b762640 (patch)
tree2a32c53a43caab1358cf9b66ff3bb0819c3d1b60 /CMakeLists.txt
parentb8a20c656537e4be748c3485d2c9541bd51e2b3d (diff)
downloaduscxml-24ac6c39a89f5b94ede80b745f68ea5f0b762640.zip
uscxml-24ac6c39a89f5b94ede80b745f68ea5f0b762640.tar.gz
uscxml-24ac6c39a89f5b94ede80b745f68ea5f0b762640.tar.bz2
Made GCC/CLang pedantic and fixed warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83626b6..16bf183 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,8 +120,10 @@ elseif(COMPILER_SUPPORTS_CXX0X_FLAG)
endif()
if(${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic")
elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL Clang)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pedantic")
elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL MSVC)
add_definitions("-D_SCL_SECURE_NO_WARNINGS")