summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-07 23:40:11 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-07 23:40:11 (GMT)
commit3a8a7a56ab604c3cca49792973c8b0c6d8a089b9 (patch)
tree43c7897a69b707d3e2038ed7608ab884cd2f8877 /CMakeLists.txt
parent36b5c7614cc896d043ddeebae1cdb4e8e94afe18 (diff)
downloaduscxml-3a8a7a56ab604c3cca49792973c8b0c6d8a089b9.zip
uscxml-3a8a7a56ab604c3cca49792973c8b0c6d8a089b9.tar.gz
uscxml-3a8a7a56ab604c3cca49792973c8b0c6d8a089b9.tar.bz2
Got rid of some warnings with gcc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfd0a38..077368a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -739,7 +739,7 @@ endforeach()
# add compile time reducer
# see https://github.com/sakra/cotire
-if ((WIN32 OR UNIX) AND NOT APPLE)
+if (NOT CMAKE_CROSSCOMPILING)
include(cotire)
endif()
@@ -751,7 +751,7 @@ else()
add_library(uscxml ${USCXML_FILES})
target_link_libraries(uscxml ${USCXML_OPT_LIBS} ${USCXML_CORE_LIBS})
endif()
-if ((WIN32 OR UNIX) AND NOT APPLE)
+if (NOT CMAKE_CROSSCOMPILING)
set_target_properties(uscxml PROPERTIES COTIRE_CXX_PREFIX_HEADER_INIT "src/uscxml/pch.h")
cotire(uscxml)
endif()