summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-01-31 19:09:52 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-01-31 19:09:52 (GMT)
commit3b321677e433dbc6f88c9e7faed0857022514efe (patch)
tree0e8dd00fdd6c0f351a74a855dfbbe1bd22d12434 /CMakeLists.txt
parentcd4d557248a14f5d28d9ce459ceb9398caab8e90 (diff)
downloaduscxml-3b321677e433dbc6f88c9e7faed0857022514efe.zip
uscxml-3b321677e433dbc6f88c9e7faed0857022514efe.tar.gz
uscxml-3b321677e433dbc6f88c9e7faed0857022514efe.tar.bz2
Only build SMTP invoker with current curl
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 19bb061..382fa56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -570,6 +570,22 @@ list (APPEND USCXML_CORE_LIBS ${CURL_LIBRARIES})
if (WIN32)
add_definitions("-DCURL_STATICLIB")
endif()
+include(CheckCXXSourceCompiles)
+
+set(CMAKE_REQUIRED_INCLUDES ${CURL_INCLUDE_DIRS})
+set(CMAKE_REQUIRED_LIBRARIES ${CURL_LIBRARIES})
+
+check_cxx_source_compiles("
+ #include <curl/curl.h>
+ int main(){return CURLOPT_MAIL_RCPT}
+" CURL_HAS_SMTP)
+
+set(CMAKE_REQUIRED_INCLUDES)
+set(CMAKE_REQUIRED_LIBRARIES)
+
+if (NOT CURL_HAS_SMTP)
+ message(STATUS "Curl missing SMTP support.")
+endif()
# GLOG
# set(ENV{GLOG_SRC} ${CMAKE_SOURCE_DIR}/../glog)