summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-02-16 12:06:12 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-02-16 12:06:12 (GMT)
commit6926b730e79e1e7bbb5080c4182d8c2862b08fdc (patch)
treef8e2d31ab8772554e560bb7581fe583a2aea9d76 /CMakeLists.txt
parent1675d444d3e118742a97f5071d523dba0af22c83 (diff)
downloaduscxml-6926b730e79e1e7bbb5080c4182d8c2862b08fdc.zip
uscxml-6926b730e79e1e7bbb5080c4182d8c2862b08fdc.tar.gz
uscxml-6926b730e79e1e7bbb5080c4182d8c2862b08fdc.tar.bz2
Started uscxml debugger
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 968e4d9..a0377bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -923,10 +923,18 @@ if (NOT CMAKE_CROSSCOMPILING)
set_target_properties(uscxml-browser PROPERTIES COTIRE_ADD_UNITY_BUILD FALSE)
# cotire(uscxml-browser)
endif()
-
set_target_properties(uscxml-browser PROPERTIES FOLDER "Apps")
install_executable(TARGETS uscxml-browser COMPONENT tools)
+ add_executable(uscxml-debug apps/uscxml-debug.cpp)
+ target_link_libraries(uscxml-debug uscxml)
+ if (NOT CMAKE_CROSSCOMPILING)
+ set_target_properties(uscxml-debug PROPERTIES COTIRE_ADD_UNITY_BUILD FALSE)
+# cotire(uscxml-browser)
+ endif()
+ set_target_properties(uscxml-debug PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-debug COMPONENT tools)
+
if (PROTOBUF_FOUND AND OFF)
file(GLOB W3C-MMI-COMMON ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.h)