summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2017-06-26 16:08:56 (GMT)
committerStefan Radomski <github@mintwerk.de>2017-06-26 16:08:56 (GMT)
commit9e639740124bfb7cc642726200aecc96a75dc916 (patch)
tree073de7bdcb42fcc3b3454c467621af7b12f4c6a0 /CMakeLists.txt
parent90a2c02e15e34a42eb011288e832ceaf58c49993 (diff)
downloaduscxml-9e639740124bfb7cc642726200aecc96a75dc916.zip
uscxml-9e639740124bfb7cc642726200aecc96a75dc916.tar.gz
uscxml-9e639740124bfb7cc642726200aecc96a75dc916.tar.bz2
Default to release build type
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f1fecb..43a978c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,12 +2,10 @@
cmake_minimum_required(VERSION 2.8.7 FATAL_ERROR)
# build type has to be set before the project definition
-SET(BUILD_TYPE_HELP "Choose the type of build, options are: None(CMAKE_CXX_FLAGS or CMAKE_C_FLAGS used) Debug, Release, RelWithDebInfo, MinSizeRel.")
-IF(DEFINED CMAKE_BUILD_TYPE)
- SET(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING ${BUILD_TYPE_HELP})
-ELSE()
- SET(CMAKE_BUILD_TYPE Release CACHE STRING ${BUILD_TYPE_HELP})
-ENDIF()
+if (NOT CMAKE_BUILD_TYPE)
+ message(STATUS "No build type selected, default to Release, options are: None(CMAKE_CXX_FLAGS or CMAKE_C_FLAGS used) Debug, Release, RelWithDebInfo, MinSizeRel.")
+ set(CMAKE_BUILD_TYPE "Release")
+endif()
# swig_add_module complains quite verbosly on newer cmake versions
SET(CMAKE_WARN_DEPRECATED OFF)