summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-28 17:26:38 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-28 17:26:38 (GMT)
commita68b6c1d31cb94675dd4dda0a2da11d8e83063c3 (patch)
treed96b56f209f2b65c703be4e611a7e3e6da899067 /CMakeLists.txt
parent1be1af2d15375dbbf20cd07e85afdf3cee23c992 (diff)
downloaduscxml-a68b6c1d31cb94675dd4dda0a2da11d8e83063c3.zip
uscxml-a68b6c1d31cb94675dd4dda0a2da11d8e83063c3.tar.gz
uscxml-a68b6c1d31cb94675dd4dda0a2da11d8e83063c3.tar.bz2
Bug fixes (see details)
- No more 100-continue HTTP header - Correctly delegate HTTP requests - More elaborate expressions when communicating via HTTP - Fixed off-by-one in JSCNodeSet
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef32b01..768b8f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,7 @@ if (APPLE)
OUTPUT_STRIP_TRAILING_WHITESPACE)
if (MACOSX_VERSION)
THREE_PART_VERSION_TO_VARS(
- "10.8"
+ ${MACOSX_VERSION}
MACOSX_VERSION_MAJOR
MACOSX_VERSION_MINOR
MACOSX_VERSION_PATCH)
@@ -381,7 +381,8 @@ endif()
set(CMAKE_COMPILER_STRING "${CMAKE_CXX_COMPILER_ID} ${CMAKE_CXX_COMPILER_VERSION}")
# see http://www.mail-archive.com/cmake@cmake.org/msg23240.html
-if (APPLE)
+if (APPLE AND MACOSX_VERSION VERSION_LESS "10.9")
+ # figure out what to do with Mavericks (10.9) later
# add_definitions("-D_DARWIN_UNLIMITED_SELECT")
# set(CMAKE_OSX_ARCHITECTURES "x86_64;i386")
# support leopard and above