summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-06-27 22:32:46 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-06-27 22:32:46 (GMT)
commitc70d02010ea99e6c8e35da3b767f41f1ee5dce56 (patch)
treea0ef030204ec2eb656845d03876006d9cdc0760c /CMakeLists.txt
parenta4b506fd774ec50ad79b7531bd3698c5a6339407 (diff)
downloaduscxml-c70d02010ea99e6c8e35da3b767f41f1ee5dce56.zip
uscxml-c70d02010ea99e6c8e35da3b767f41f1ee5dce56.tar.gz
uscxml-c70d02010ea99e6c8e35da3b767f41f1ee5dce56.tar.bz2
Major header movement
- Used IWYU to reorganize headers - Dropped PHP support - Updated tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90e5316..6a26928 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -358,6 +358,8 @@ if(${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU")
if(GCC_VERSION VERSION_EQUAL 4.7 OR GCC_VERSION VERSION_GREATER 4.7)
# when compiling as C++11, narrowing is a warning but older compilers complain about the option
add_definitions(-Wno-narrowing)
+ # recent gcc started to complain about unused globals
+ add_definitions(-Wno-unused-variable)
endif()
if(GCC_VERSION VERSION_EQUAL 4.8 OR GCC_VERSION VERSION_GREATER 4.8)
@@ -946,6 +948,8 @@ foreach( FILE ${USCXML_FILES} )
elseif (${FILE} MATCHES ".*\\/debug\\/.*")
source_group("Interpreter\\debug" FILES ${FILE})
+ elseif (${FILE} MATCHES ".*\\/plugins\\/.*")
+ source_group("Interpreter\\plugins" FILES ${FILE})
elseif (${FILE} MATCHES ".*\\/transform\\/.*")
source_group("Interpreter\\transform" FILES ${FILE})
elseif (${FILE} MATCHES ".*\\/util\\/.*")
@@ -954,6 +958,8 @@ foreach( FILE ${USCXML_FILES} )
source_group("Interpreter\\concurrency" FILES ${FILE})
elseif (${FILE} MATCHES ".*\\/server\\/.*")
source_group("Interpreter\\server" FILES ${FILE})
+ elseif (${FILE} MATCHES ".*\\/messages\\/.*")
+ source_group("Interpreter\\messages" FILES ${FILE})
else ()
source_group(Interpreter FILES ${FILE})