summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-06-13 12:08:01 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-06-13 12:08:01 (GMT)
commitd304f85417e3175c5f2ca159dd303309c24e7b81 (patch)
tree2a065da122e61cf75c6e7c51adc35d654f45600a /CMakeLists.txt
parent7238020a20213fba109b517a77f526e39d5a92f7 (diff)
downloaduscxml-d304f85417e3175c5f2ca159dd303309c24e7b81.zip
uscxml-d304f85417e3175c5f2ca159dd303309c24e7b81.tar.gz
uscxml-d304f85417e3175c5f2ca159dd303309c24e7b81.tar.bz2
Fixed build errors
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 15 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a7b463..bc48b2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -524,19 +524,21 @@ target_link_libraries(uscxml-browser uscxml)
set_target_properties(uscxml-browser PROPERTIES FOLDER "Apps")
install_executable(TARGETS uscxml-browser COMPONENT tools)
-file(GLOB W3C-MMI-COMMON ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.h)
-
-file(GLOB_RECURSE W3C-MMI-IM ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.h)
-add_executable(uscxml-interaction-manager ${W3C-MMI-IM} ${W3C-MMI-COMMON})
-target_link_libraries(uscxml-interaction-manager uscxml)
-set_target_properties(uscxml-interaction-manager PROPERTIES FOLDER "Apps")
-install_executable(TARGETS uscxml-interaction-manager COMPONENT tools)
-
-file(GLOB_RECURSE W3C-MMI-MC ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.h)
-add_executable(uscxml-modality-component ${W3C-MMI-MC} ${W3C-MMI-COMMON})
-target_link_libraries(uscxml-modality-component uscxml)
-set_target_properties(uscxml-modality-component PROPERTIES FOLDER "Apps")
-install_executable(TARGETS uscxml-modality-component COMPONENT tools)
+if (PROTOBUF_FOUND)
+ file(GLOB W3C-MMI-COMMON ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.h)
+
+ file(GLOB_RECURSE W3C-MMI-IM ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.h)
+ add_executable(uscxml-interaction-manager ${W3C-MMI-IM} ${W3C-MMI-COMMON})
+ target_link_libraries(uscxml-interaction-manager uscxml)
+ set_target_properties(uscxml-interaction-manager PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-interaction-manager COMPONENT tools)
+
+ file(GLOB_RECURSE W3C-MMI-MC ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.h)
+ add_executable(uscxml-modality-component ${W3C-MMI-MC} ${W3C-MMI-COMMON})
+ target_link_libraries(uscxml-modality-component uscxml)
+ set_target_properties(uscxml-modality-component PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-modality-component COMPONENT tools)
+endif()
if (BUILD_TESTS)
add_subdirectory(test)