summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2017-05-30 19:48:04 (GMT)
committerStefan Radomski <github@mintwerk.de>2017-05-30 19:48:04 (GMT)
commitd6cf6e2f11e0055707ec810928d75e82d9ed9ec2 (patch)
tree2850b9fe12d923a3fab94e97f0bdcafacc4a9db1 /CMakeLists.txt
parentca31d356e44e19649eeb8340eb1451ea3f477cfa (diff)
downloaduscxml-d6cf6e2f11e0055707ec810928d75e82d9ed9ec2.zip
uscxml-d6cf6e2f11e0055707ec810928d75e82d9ed9ec2.tar.gz
uscxml-d6cf6e2f11e0055707ec810928d75e82d9ed9ec2.tar.bz2
Updated libevent version for SSL support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e9ca8e..c8a3545 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -253,6 +253,13 @@ else()
endif()
endif()
+#OpenSSL
+find_package(OpenSSL)
+if (OPENSSL_FOUND)
+ include_directories(${OPENSSL_INCLUDE_DIR})
+ list (APPEND USCXML_CORE_LIBS ${OPENSSL_LIBRARIES})
+endif()
+
# XercesC
CheckHasModule(XercesC)
@@ -328,13 +335,10 @@ if (UNIX)
list (APPEND USCXML_CORE_LIBS "pthread")
endif()
-#OpenSSL
-find_package(OpenSSL)
-if (OPENSSL_FOUND)
- include_directories(${OPENSSL_INCLUDE_DIR})
- list (APPEND USCXML_CORE_LIBS ${OPENSSL_LIBRARIES})
-endif()
+if (OPENSSL_FOUND AND LIBEVENT_HAS_BEVCB AND EVENT_SSL_FOUND)
+ set(HTTPS_ENABLED ON)
+endif()
# uriparser - part of contrib now