summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2016-08-22 14:53:14 (GMT)
committerStefan Radomski <github@mintwerk.de>2016-08-22 14:53:14 (GMT)
commite5782b214d839fe5d8b2f527ae331a246c6e012f (patch)
tree246e5bf1143b72267791e682b1ac37991d26adbe /CMakeLists.txt
parentdb8418fb9f733ca0147cc225ce0988d7866f15cd (diff)
downloaduscxml-e5782b214d839fe5d8b2f527ae331a246c6e012f.zip
uscxml-e5782b214d839fe5d8b2f527ae331a246c6e012f.tar.gz
uscxml-e5782b214d839fe5d8b2f527ae331a246c6e012f.tar.bz2
Progress on the apache-commons wrapper
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cca6649..d5110dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -371,6 +371,18 @@ if (WITH_DM_LUA)
endif()
OPTION(WITH_DM_C89 "Do build with C89 datamodel support" OFF)
+if (WITH_DM_C89)
+ include("${CMAKE_MODULE_PATH}/BuildPicoC.cmake")
+ message(STATUS "Did not look for picoc interpreter")
+ message(STATUS "--> will download and compile")
+ if (PICOC_BUILT)
+ include_directories(${PICOC_INCLUDE_DIR})
+ list (APPEND USCXML_CORE_LIBS ${PICOC_LIBRARY})
+ list (APPEND USCXML_PREREQS picoc)
+ else()
+ message(FATAL_ERROR "Could not build picoc")
+ endif()
+endif()
add_subdirectory(src/uscxml)
add_subdirectory(src/bindings)