summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-07-23 09:25:44 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-07-23 09:25:44 (GMT)
commiteb99c62e3d00f4ea5271f6dfc6401e3fcd5a5b90 (patch)
treec57585368b5855b7f71c5383d045d428a249ef8b /CMakeLists.txt
parent122285d16fd8ac9855c92519d48919bea36791b4 (diff)
downloaduscxml-eb99c62e3d00f4ea5271f6dfc6401e3fcd5a5b90.zip
uscxml-eb99c62e3d00f4ea5271f6dfc6401e3fcd5a5b90.tar.gz
uscxml-eb99c62e3d00f4ea5271f6dfc6401e3fcd5a5b90.tar.bz2
Fixed setting intial config
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt56
1 files changed, 33 insertions, 23 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ba758f..a776753 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,13 @@ if (CMAKE_CROSSCOMPILING AND ANDROID_ABI)
set(CMAKE_SYSTEM_VERSION ${ANDROID_NATIVE_API_LEVEL})
endif()
+if (CMAKE_CROSSCOMPILING)
+ if (IOS)
+ add_definitions(-DTARGET_OS_IPHONE)
+ elseif(IOSSIM)
+ add_definitions(-DTARGET_IPHONE_SIMULATOR)
+ endif()
+endif()
#
# Setting the CMAKE_FIND_ROOT_PATH to a list of directories will cause all CMake modules
# to look in these directories in addition to the system search paths:
@@ -211,7 +218,7 @@ if(${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU")
# order of arguments of gcc matters again
# set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
add_definitions(-fPIC)
- add_definitions(-Wunreachable-code)
+ #add_definitions(-Wunreachable-code)
if (CMAKE_BUILD_TYPE MATCHES ".*Deb.*" AND ENABLE_GCOV) # when not building for debug
# coverage information
@@ -610,34 +617,37 @@ else()
target_link_libraries(uscxml ${USCXML_OPT_LIBS} ${USCXML_CORE_LIBS})
endif()
-add_executable(uscxml-browser apps/uscxml-browser.cpp ${PROJECT_SOURCE_DIR}/contrib/src/getopt/XGetopt.cpp)
-target_link_libraries(uscxml-browser uscxml)
-set_target_properties(uscxml-browser PROPERTIES FOLDER "Apps")
-install_executable(TARGETS uscxml-browser COMPONENT tools)
+if (NOT CMAKE_CROSSCOMPILING)
+ add_executable(uscxml-browser apps/uscxml-browser.cpp ${PROJECT_SOURCE_DIR}/contrib/src/getopt/XGetopt.cpp)
+ target_link_libraries(uscxml-browser uscxml)
+ set_target_properties(uscxml-browser PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-browser COMPONENT tools)
-if (PROTOBUF_FOUND)
- file(GLOB W3C-MMI-COMMON ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.h)
+ if (PROTOBUF_FOUND)
+ file(GLOB W3C-MMI-COMMON ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.h)
- file(GLOB_RECURSE W3C-MMI-IM ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.h)
- add_executable(uscxml-interaction-manager ${W3C-MMI-IM} ${W3C-MMI-COMMON})
- target_link_libraries(uscxml-interaction-manager uscxml)
- set_target_properties(uscxml-interaction-manager PROPERTIES FOLDER "Apps")
- install_executable(TARGETS uscxml-interaction-manager COMPONENT tools)
+ file(GLOB_RECURSE W3C-MMI-IM ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.h)
+ add_executable(uscxml-interaction-manager ${W3C-MMI-IM} ${W3C-MMI-COMMON})
+ target_link_libraries(uscxml-interaction-manager uscxml)
+ set_target_properties(uscxml-interaction-manager PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-interaction-manager COMPONENT tools)
- file(GLOB_RECURSE W3C-MMI-MC ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.h)
- add_executable(uscxml-modality-component ${W3C-MMI-MC} ${W3C-MMI-COMMON})
- target_link_libraries(uscxml-modality-component uscxml)
- set_target_properties(uscxml-modality-component PROPERTIES FOLDER "Apps")
- install_executable(TARGETS uscxml-modality-component COMPONENT tools)
-endif()
+ file(GLOB_RECURSE W3C-MMI-MC ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/mc/*.h)
+ add_executable(uscxml-modality-component ${W3C-MMI-MC} ${W3C-MMI-COMMON})
+ target_link_libraries(uscxml-modality-component uscxml)
+ set_target_properties(uscxml-modality-component PROPERTIES FOLDER "Apps")
+ install_executable(TARGETS uscxml-modality-component COMPONENT tools)
+ endif()
-if (BUILD_TESTS)
- add_subdirectory(test)
+ if (BUILD_TESTS)
+ add_subdirectory(test)
+ endif()
+
+ if (NOT WIN32)
+ add_subdirectory(src/bindings)
+ endif()
endif()
-if (NOT WIN32)
- add_subdirectory(src/bindings)
-endif()
############################################################
# Header Files