summaryrefslogtreecommitdiffstats
path: root/src/uscxml/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-25 20:36:03 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-04-25 20:36:03 (GMT)
commit00f5d8af3c8e42ba8a0d0c206d2c2e8f1867a61e (patch)
treeafa4183b1bb4ee777cad27475c3d7679822c8046 /src/uscxml/CMakeLists.txt
parent4d6fb580b1c1378cb1441fff4adeca889cbba58e (diff)
downloaduscxml-00f5d8af3c8e42ba8a0d0c206d2c2e8f1867a61e.zip
uscxml-00f5d8af3c8e42ba8a0d0c206d2c2e8f1867a61e.tar.gz
uscxml-00f5d8af3c8e42ba8a0d0c206d2c2e8f1867a61e.tar.bz2
Refactored CMakeLists and updated W3C tests
Diffstat (limited to 'src/uscxml/CMakeLists.txt')
-rw-r--r--src/uscxml/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/uscxml/CMakeLists.txt b/src/uscxml/CMakeLists.txt
new file mode 100644
index 0000000..3167405
--- /dev/null
+++ b/src/uscxml/CMakeLists.txt
@@ -0,0 +1,58 @@
+############################################################
+# Actual files of core library
+############################################################
+
+file(GLOB_RECURSE USCXML_SERVER
+ src/uscxml/server/*.cpp
+ src/uscxml/server/*.h
+)
+source_group("Interpreter" FILES ${USCXML_SERVER})
+list (APPEND USCXML_FILES ${USCXML_SERVER})
+
+file(GLOB_RECURSE USCXML_CONCURRENCY
+ src/uscxml/concurrency/*.cpp
+ src/uscxml/concurrency/*.h
+)
+source_group("Interpreter" FILES ${USCXML_CONCURRENCY})
+list (APPEND USCXML_FILES ${USCXML_CONCURRENCY})
+
+file(GLOB_RECURSE USCXML_DEBUG
+ src/uscxml/debug/*.cpp
+ src/uscxml/debug/*.h
+)
+source_group("Interpreter" FILES ${USCXML_DEBUG})
+list (APPEND USCXML_FILES ${USCXML_DEBUG})
+
+file(GLOB_RECURSE USCXML_INTERPRETERS
+ src/uscxml/interpreter/*.cpp
+ src/uscxml/interpreter/*.h
+)
+source_group("Interpreter" FILES ${USCXML_INTERPRETERS})
+list (APPEND USCXML_FILES ${USCXML_INTERPRETERS})
+
+file(GLOB USCXML_CORE
+ ${CMAKE_SOURCE_DIR}/contrib/src/jsmn/jsmn.c
+ src/uscxml/*.cpp
+ src/uscxml/*.h
+)
+source_group("Interpreter" FILES ${USCXML_CORE})
+list (APPEND USCXML_FILES ${USCXML_CORE})
+
+if (BUILD_AS_PLUGINS)
+ list (APPEND USCXML_INCLUDE_DIRS ${PROJECT_SOURCE_DIR}/src/uscxml/plugins)
+ file(GLOB PLUMA
+ src/uscxml/plugins/Pluma/*.cpp
+ src/uscxml/plugins/Pluma/*.h
+ src/uscxml/plugins/*.cpp
+ src/uscxml/plugins/*.h
+ )
+ source_group("Interpreter" FILES ${PLUMA})
+ list (APPEND USCXML_FILES ${PLUMA})
+ add_definitions("-DBUILD_AS_PLUGINS")
+endif()
+
+include(src/uscxml/plugins/datamodel/CMakeLists.txt)
+include(src/uscxml/plugins/element/CMakeLists.txt)
+include(src/uscxml/plugins/invoker/CMakeLists.txt)
+include(src/uscxml/plugins/ioprocessor/CMakeLists.txt)
+