summaryrefslogtreecommitdiffstats
path: root/src/uscxml/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-07-31 21:05:47 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-07-31 21:05:47 (GMT)
commita61ef07b5eb3dacfc596a26cb1373356e5673dbb (patch)
tree484f4c1952c493032f8ca42709e001d7cc25be6a /src/uscxml/CMakeLists.txt
parenteab5c12b2a1b9cfee94e8d0cbe41fb5d78594bb5 (diff)
downloaduscxml-a61ef07b5eb3dacfc596a26cb1373356e5673dbb.zip
uscxml-a61ef07b5eb3dacfc596a26cb1373356e5673dbb.tar.gz
uscxml-a61ef07b5eb3dacfc596a26cb1373356e5673dbb.tar.bz2
Support for ignoring libraries when building and minimal builds
Diffstat (limited to 'src/uscxml/CMakeLists.txt')
-rw-r--r--src/uscxml/CMakeLists.txt26
1 files changed, 14 insertions, 12 deletions
diff --git a/src/uscxml/CMakeLists.txt b/src/uscxml/CMakeLists.txt
index c38bcbf..d74f512 100644
--- a/src/uscxml/CMakeLists.txt
+++ b/src/uscxml/CMakeLists.txt
@@ -32,19 +32,21 @@ file(GLOB_RECURSE USCXML_MESSAGES
source_group("Interpreter" FILES ${USCXML_MESSAGES})
list (APPEND USCXML_FILES ${USCXML_MESSAGES})
-file(GLOB_RECURSE USCXML_DEBUG
- debug/*.cpp
- debug/*.h
-)
-source_group("Interpreter" FILES ${USCXML_DEBUG})
-list (APPEND USCXML_FILES ${USCXML_DEBUG})
+if (NOT BUILD_MINIMAL)
+ file(GLOB_RECURSE USCXML_DEBUG
+ debug/*.cpp
+ debug/*.h
+ )
+ source_group("Interpreter" FILES ${USCXML_DEBUG})
+ list (APPEND USCXML_FILES ${USCXML_DEBUG})
-file(GLOB_RECURSE USCXML_TRANSFORM
- transform/*.cpp
- transform/*.h
-)
-source_group("Interpreter" FILES ${USCXML_TRANSFORM})
-list (APPEND USCXML_FILES ${USCXML_TRANSFORM})
+ file(GLOB_RECURSE USCXML_TRANSFORM
+ transform/*.cpp
+ transform/*.h
+ )
+ source_group("Interpreter" FILES ${USCXML_TRANSFORM})
+ list (APPEND USCXML_FILES ${USCXML_TRANSFORM})
+endif()
file(GLOB_RECURSE USCXML_INTERPRETERS
interpreter/*.cpp