summaryrefslogtreecommitdiffstats
path: root/src/uscxml/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-06-27 22:32:46 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-06-27 22:32:46 (GMT)
commitc70d02010ea99e6c8e35da3b767f41f1ee5dce56 (patch)
treea0ef030204ec2eb656845d03876006d9cdc0760c /src/uscxml/CMakeLists.txt
parenta4b506fd774ec50ad79b7531bd3698c5a6339407 (diff)
downloaduscxml-c70d02010ea99e6c8e35da3b767f41f1ee5dce56.zip
uscxml-c70d02010ea99e6c8e35da3b767f41f1ee5dce56.tar.gz
uscxml-c70d02010ea99e6c8e35da3b767f41f1ee5dce56.tar.bz2
Major header movement
- Used IWYU to reorganize headers - Dropped PHP support - Updated tests
Diffstat (limited to 'src/uscxml/CMakeLists.txt')
-rw-r--r--src/uscxml/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/uscxml/CMakeLists.txt b/src/uscxml/CMakeLists.txt
index da620fb..c38bcbf 100644
--- a/src/uscxml/CMakeLists.txt
+++ b/src/uscxml/CMakeLists.txt
@@ -25,6 +25,13 @@ file(GLOB_RECURSE USCXML_CONCURRENCY
source_group("Interpreter" FILES ${USCXML_CONCURRENCY})
list (APPEND USCXML_FILES ${USCXML_CONCURRENCY})
+file(GLOB_RECURSE USCXML_MESSAGES
+ messages/*.cpp
+ messages/*.h
+)
+source_group("Interpreter" FILES ${USCXML_MESSAGES})
+list (APPEND USCXML_FILES ${USCXML_MESSAGES})
+
file(GLOB_RECURSE USCXML_DEBUG
debug/*.cpp
debug/*.h
@@ -63,6 +70,16 @@ file(GLOB USCXML_CORE
source_group("Interpreter" FILES ${USCXML_CORE})
list (APPEND USCXML_FILES ${USCXML_CORE})
+file(GLOB USCXML_PLUGINS
+ plugins/DataModel.h
+ plugins/EventHandler.h
+ plugins/ExecutableContent.h
+ plugins/Invoker.h
+ plugins/IOProcessor.h
+)
+source_group("Interpreter" FILES ${USCXML_PLUGINS})
+list (APPEND USCXML_FILES ${USCXML_PLUGINS})
+
if (BUILD_AS_PLUGINS)
list (APPEND USCXML_INCLUDE_DIRS ${PROJECT_SOURCE_DIR}/plugins)
file(GLOB PLUMA