summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/element/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-09-02 21:38:10 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-09-02 21:38:10 (GMT)
commit7938e286967597c7168b855b7e3fdfbd9b949e0e (patch)
treebc5d9bfb80a07ec80b36dc025b3fac9f3ca03ec4 /src/uscxml/plugins/element/CMakeLists.txt
parenta874a181add7b292e52140f8c753f663a4cb5a87 (diff)
downloaduscxml-7938e286967597c7168b855b7e3fdfbd9b949e0e.zip
uscxml-7938e286967597c7168b855b7e3fdfbd9b949e0e.tar.gz
uscxml-7938e286967597c7168b855b7e3fdfbd9b949e0e.tar.bz2
New file element for executable content
Diffstat (limited to 'src/uscxml/plugins/element/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/element/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/uscxml/plugins/element/CMakeLists.txt b/src/uscxml/plugins/element/CMakeLists.txt
index f24a609..fd69417 100644
--- a/src/uscxml/plugins/element/CMakeLists.txt
+++ b/src/uscxml/plugins/element/CMakeLists.txt
@@ -53,6 +53,25 @@ else()
endif()
+# File element
+
+set(USCXML_ELEMENTS "file ${USCXML_ELEMENTS}")
+file(GLOB_RECURSE FILE_ELEMENT
+ file/*.cpp
+ file/*.h
+)
+source_group("Element\\file" FILES ${FILE_ELEMENT})
+if (BUILD_AS_PLUGINS)
+ add_library(
+ element_file SHARED
+ ${FILE_ELEMENT})
+ target_link_libraries(element_file uscxml)
+ set_target_properties(element_file PROPERTIES FOLDER "Plugin Element")
+else()
+ list (APPEND USCXML_FILES ${FILE_ELEMENT})
+endif()
+
+
# Respond element
set(USCXML_ELEMENTS "respond ${USCXML_ELEMENTS}")