summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/invoker/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-05-22 07:40:35 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-05-22 07:40:35 (GMT)
commit1e66bfd04f864a040b1e4a68f0db0f55f15b91a3 (patch)
treec254dc899d79e0fc6962ef2d2d5dfc26de1a6766 /src/uscxml/plugins/invoker/CMakeLists.txt
parentf9a620340ddce2a17fd775d1e210268cac13377b (diff)
downloaduscxml-1e66bfd04f864a040b1e4a68f0db0f55f15b91a3.zip
uscxml-1e66bfd04f864a040b1e4a68f0db0f55f15b91a3.tar.gz
uscxml-1e66bfd04f864a040b1e4a68f0db0f55f15b91a3.tar.bz2
Builds with MSVC again
Diffstat (limited to 'src/uscxml/plugins/invoker/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/invoker/CMakeLists.txt25
1 files changed, 17 insertions, 8 deletions
diff --git a/src/uscxml/plugins/invoker/CMakeLists.txt b/src/uscxml/plugins/invoker/CMakeLists.txt
index 9127155..8ae4516 100644
--- a/src/uscxml/plugins/invoker/CMakeLists.txt
+++ b/src/uscxml/plugins/invoker/CMakeLists.txt
@@ -274,12 +274,18 @@ endif()
# UMUNDO invoker
-if (UMUNDO_FOUND)
+if (UMUNDO_FOUND AND PROTOBUF_FOUND)
set(USCXML_INVOKERS "umundo ${USCXML_INVOKERS}")
- file(GLOB_RECURSE UMUNDO_INVOKER
- umundo/*.cpp
- umundo/*.cc
- umundo/*.h)
+ set(UMUNDO_INVOKER
+ ${CMAKE_CURRENT_SOURCE_DIR}/umundo/UmundoInvoker.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/umundo/UmundoInvoker.h
+ )
+ if (PROTOBUF_FOUND)
+ list(APPEND UMUNDO_INVOKER
+ ${CMAKE_CURRENT_SOURCE_DIR}/umundo/JSON.pb.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/umundo/JSON.pb.h
+ )
+ endif()
if (BUILD_AS_PLUGINS)
source_group("" FILES ${UMUNDO_INVOKER})
# message(FATAL_ERROR "UMUNDO_LIBRARIES: ${UMUNDO_LIBRARIES}")
@@ -288,9 +294,12 @@ if (UMUNDO_FOUND)
${UMUNDO_INVOKER}
"../Plugins.cpp")
target_link_libraries(invoker_umundo uscxml
- optimized ${PROTOBUF_LIBRARY}
- debug ${PROTOBUF_LIBRARY_DEBUG}
- ${UMUNDO_LIBRARIES})
+ ${UMUNDO_LIBRARIES})
+ if (PROTOBUF_FOUND)
+ target_link_libraries(invoker_umundo
+ optimized ${PROTOBUF_LIBRARY}
+ debug ${PROTOBUF_LIBRARY_DEBUG})
+ endif()
set_target_properties(invoker_umundo PROPERTIES FOLDER "Plugin Invoker")
else()
list (APPEND USCXML_FILES ${UMUNDO_INVOKER})